Back to overview
Degraded
Organization Settings is experiencing degraded performance across older versions of Chrome
May 23 at 12:31pm HDT
Affected services
Application
Resolved
May 23 at 12:52pm HDT
We have pushed some improvements to the input fields within the Organization Settings page and will continue to monitor and improve tests, expanding our browser support as much as possible.
Affected services
Application
Created
May 23 at 12:31pm HDT
Currently, when attempting to fill-out the "industries" within the Organization Settings page, it causes some older versions of the Chrome Browser to freeze. We are working on identifying the cause and will push a fix.
Affected services
Application